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Prosoniq VIPEX3 Quickstart Guide

Introduction

The MPEX3 algorithm for Pyramix Virtual Studio has been developed together with the German based company
Prosoniq, who are known for their high quality digital audio algorithms. MPEX stands for Minimum Perceived
Loss Time Compression/Expansion. Incorporating this technology into Pyramix Virtual Studio gives users the
opportunity to adjust timing and pitch of their existing material with outstanding results and ease of use.

MPEX3 Time Scaling Algorithm

Time Scaling (also known as 'Time Stretching’, Time Compression/Expansion’ and Time Correction') is the process
of changing a sound's length without changing its pitch. When transposing a sound by playing it back at a differ-
ent speed, like when slowing down the playback speed of a tape recorder, it will play back at a different tempo but
also at a different pitch. While this may be fine when tuning drum loops to match the speed of a recording it will
make pitched sounds - like vocals - sound totally out of tune. Thus it is desirable to provide a process that enables
you to change duration and pitch of a recording independently from each other.

MPEX changes duration using a novel Timebase Compression/Expansion algorithm leaving the tonal information
untouched. This is a very useful feature if you plan to synchronize spoken text to a movie or if you need to adapt
the tempo of a vocal track to a song (e.g. for remixing purposes).

The algorithm does not alter the timing structure of the audio material in any way thus providing an accurate time
compression/expansion tool for applications where the relative timing of instruments or acoustic cues is critical
(such as in drum loops). MPEX also includes high quality pitch conversion for changing pitch without affecting
sample length. This can be invoked by simply setting the pitchScale parameter to an appropriate value.

Formant Preservation

An important feature of MPEX is its ability to preserve the harmonic structure of a sound, making transposition
artifacts such as the munchkinization effect history. MPEX is capable of transposing a sound over a wide range of
semitones without altering its timbre. This makes MPEX an ideal tool for doubling vocal passages in a song, or
altering the timbre or gender of a voice

Long Term Stability and Precision

Unlike many other time and pitch change algorithms, MPEX has been fully tested for long-term stability. This is
important when time stretching extremely long musical pieces, for example an entire film score. Even small factor
conversions (such as 30/29 fps PAL/NTSC) are guaranteed not to cause loss of sync.

‘ Prosoniq MPEX3 Quickstart Guide : Introduction
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Multi-channel processing

Phase Coherent Processing

Maintaining phase coherence between all channels in a multi-channel recording is essential in some circum-
stances but unnecessary in others. In a stereo recording, the relative timing (or phase relationship) between the
left and the right channels provide important localization cues to the listener. If time-stretching software changes
the relative timing of the two channels by even a minimal amount, stereo imaging will be degraded or even lost.
Mono compatibility will no longer be guaranteed, since when the Left and Right channels are mixed down to a
single mono channel (just as occurs in some domestic reproduction equipment) there will be audible artifacts
perceived as phasing or cancellations.

When to use Phase-Locked

If relative phase between channels matters, it is imperative to use the Phase Locked multi-channel processing
mode of MPEX (all channels are being processed at the same time). As a rule of thumb, this is always the case with
stereo recordings, or recordings of the same sound source through different microphones. It is almost always the
case with the channels in a surround mix. In these cases, you should use MPEX in multi-channel mode, by process-
ing a single multi-channel file.

Relative phase is usually unimportant in a multi-track environment where different instruments reside on different
tracks. In such cases, phase-locked processing can be detrimental with regard to the sonic quality of the time or
pitch change operation and should be avoided.

Important! The Prosoniq algorithm is able the preserve the phase between up to 128 channels. To
ensure phase preservation, the audio media file to be Stretched, Compressed and/or Pitch changed must
be a single file. l.e. all the channels must reside in the same file and not spread into multiple mono files as
would be the case when One file per track is selected for recording.

Existing multi-channel source material

If the multi-track material you wish to process is not in a single file simply select the material and choose Project >
Render to open the Render Window. Make sure <None> is selected in the Rendering Process box and that the
One file per track box is NOT checked. If required, make other settings suitable for your needs and click the Ren-
der button.

‘ Prosoniq MPEX3 Quickstart Guide : Introduction
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Accessing MPEX3

Pyramix Virtual Studio gives you the opportunity to access MPEX3 from several strategic locations (see below).

{Prmnlq MPEX3 : lInit @I
Prosoniq

T seal Piteh seale

Mabn

Onginal TC

Criganal Tempo
Desired Tempo

Prewiew beegeh

Main Prosoniq win-

You can adjust the timing for sound-to-picture format matching, either during post-processing or for your entire
project. You also have the choice of adjusting the length of clips in a very handy and accurate manner in the Time-
line, directly in the Media Management Tab window using Quick Convert or applying pitch and time modifica-
tions to selected clips with the Rendering function. Check the Phase Locked box if the tracks to be stretched are
correlated.

‘ Prosoniq MPEX3 Quickstart Guide : Accessing MPEX3
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Tuning the Algorithm

The two combo boxes MPEX Quality and Formant Type offer a choice of algorithms:

MPEX Quality

Single Instrument Fast Fast algorithm for processing single instruments (musically monophonic material)
and voice.

Single Instrument Best Higher quality algorithm for processing single instruments (musically monophonic
material) and voice.

Polyphonic Fast General multi-purpose algorithm for processing musically monophonic and poly-
phonic material. This is the fastest setting that gives still very good results. Should
be used for anything beyond single instruments, e.g. For drum loops, mixes,
chords...

Polyphonic Good General multi-purpose algorithm for processing musically monophonic and poly-
phonic material. This is the recommended MPEX default quality setting.
Should be used for anything beyond single instruments, e.g. For drum loops,
mixes, chords...

Polyphonic Best This is the best setting of all. It is quite processor intensive and should be used only
when processing difficult material or if a very large (>1.3) stretch factor is desired.

Formant Type

Sung Voice

Spoken Voice

Note: When Previewing a render, MPEX uses a special Preview quality which is faster
than the user choices above.

‘ Prosoniq MPEX3 Quickstart Guide : Accessing MPEX3
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Project Menu

Stretch/Pitch

Project > Stretch / Pitch opens this dialog:.

' _— .

Multichannel Time Stretch & Pitch Sc Prosoniac
Stretch

@) 24 fps to 25 fps (4% time compression)

Origin Reference 00:12:48:17

25 fps to 24 fps (4. 17% time expansion)

Pitch

24 fps to 25 fps (4% pitch reduction)

25 fps to 24 fps (4. 17% pitch rise)

MPEX3 Settings

Quality Mode : |Polyphonic Good i |
Formant Type : |Sung Yoice v |
Target Settings

@) Use Project Settings (Project Folder or Original Place)

LIse Custom Media Folder

Options

Format |F'MF {Recommended) - | Settings

| Consolidate Handles 1 [5]

W W

Stretch Cancel

Stretch / Pitch dialog

Stretch adjusts the duration of your entire project from 25 fps to 24 fps, or from 24 fps to 25 fps. Alternatively,
Pitch can be changed by the same percentages. This can be useful where material has already been stretched
without pitch correction. MPEX3 Settings offer the same choices shown on the previous page.

‘ Prosoniq MPEX3 Quickstart Guide : Project Menu
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Render

‘AMERGING

Project > Render opens the Render window. Double clicking on Prosoniq MPEX3 in the list opens this dialog:

{Prmnlq MPEX3 : lInit @I
Multichannel Time Stretch & Pitch Scaling by (s (e 111 JR ¢

elers

Piteh reale

Samdonas

Fing

Prewiew beegeh

Main Prosoniq win-

Time And Pitch Parameters
Time scale and Pitch scale can be manipulated in a number of ways.

. By entering a ratio

. By altering TimeCode values

. By altering tempo values

. By altering Pitch and Formant values

. By clicking and dragging the golden ball in the graphic display

When the Preserve Formants button is lit, movement of the golden ball is constrained to the blue curve.

Processing is limited to 128 channels in one operation

Prosoniq MPEX3 Quickstart Guide : Project Menu
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Edit Menu

Stretch

Criginal

In 00:00:00:02 In 00:00:00:02
Out 00:02:59:01 Out 00:02:59:01
Length 00:02:58:23 - Length 00:02:58:23

Ratio | piaaax] oy

Options
The type of Time Stretch algorithm depending your authorization keys
can be selected in All Settings = Application = Editing

The Time Stretch quality parameters and other settings can be setin
All Settings = Application > Time Stretch

Stretch dialog

When a Clip or portion of a Clip is selected in the Timeline, choosing Edit > Stretch opens this dialog. Here, you
can make choices about duration expansion / reduction. You may also indicate the desired stretched size by plac-
ing the Playhead cursor at the intended position and the numbers will adjust accordingly in the pop-up dialog.

Media Management

Quick Convert
If a Master Clip is selected and Convert > Quick Convert > Prosoniq MPEX2 is chosen, this dialog opens:

@ Mew name Bone Machine_A LitHe Rain

Add Suffix

Keep Criginal File Format

Properties... | | K, 3 Cancel

MPEX3 Quick Convert dialog

‘ Prosoniq MPEX3 Quickstart Guide : Edit Menu
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Clicking on the Properties button opens this dialog:

" ™
Prosonia MPEXS Properis SN e

Settings
Stretch

24 fps to 26 fps (4% time compression]

@ 25 fpz to 24 fpz [4.17% time expanzion]

Fitch

24 fpz to 26 fpz (4% pitch reduction]

25 fpz to 24 fps [4.17% pitch rize]

FMPE=3 Settings

Huality Mode : | Polyphonic Good s |
Farmart Type | Sung Yoice - |
oK ] | Cancel Apph

MPEX3 Quick Convert Properties dialog

offering time or pitch scaling of plus 4% or minus 4.17%, for time adjustments of 24 to 25 fps or 25 to 24 fps for
sound-to-picture matching.

Choose the desired Quality Mode : from the drop-down menu and the Formant Type.

Click on OK in this dialog and the previous one to begin the conversion.

‘ Prosoniq MPEX3 Quickstart Guide : Media Management
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Surround Post-processing

Project > Surround Post-processing opens the Surround Post-processing window.

Target Settings Source Stem
Destination File Name
Surround Mix A
Wenz 25FP3 Surround Mix B
Destination File Location Surround Mix C
| ) &=
Process Record
m_l‘:‘h.:l?ll.ﬁ.lumdin :FEHES__ — n @ Whale composition
Resampler
Between Marks
Processing
Real time
Settings... |
Company: Prosonig %g - i
Description: Cinema 24fps <-= 25fps Time Stretcher a &
Process Stop Abaort

Surround Post-processing dialog

Click on Prosoniq MPEX3 24/25 Time Stretcher in the list to select it.
Make Target Settings as required and choose a Source Stem from the list..

Choose whether to Record the Whole Composition, Between Marks or a Selection if there is one.

If you wish to hear the process while recording check the Real Time box.

‘ Prosoniq MPEX3 Quickstart Guide : Surround Post-processing
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Then click on Settings... to open the Properties dialog:

. ™
Prosonig MPEX3 24/25 Time Stretcher Properties [&J
B e

Settings
Processing Mode

@ 24 fpz to 25 fps [4% time comprezsion)

25 fpz to 24 fpz [4% time expanzion]

Froceszzing Optionz

[uality Mode | Paolyphohic Good - |

Formant Tepe : | Sung Yoice - |

o | Phaze Locked [check this box if tracks are corelated)

File Farmat YWiord Length
@ PMF 32 bits [float)
BwF [ ave) @ 24 hits
AlFF 16 bitz
Optionz

One File Per Track

QK ] | Cancel Apph

Prosoniq MPEX3 24/25 Time Stretcher Properties dialog

Choose the required time-stretch option in the Processing Mode section. Make appropriate Quality Mode and
Formant Type selections and check the Phase Locked box if the tracks to be stretched are correlated. Choose the
required output file options File Format and Bit Depth and click OK to initiate the process.

‘ Prosoniq MPEX3 Quickstart Guide : Surround Post-processing
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